All services are down
Resolved
May 20, 2026 at 1:35am UTC
Primary infrastructure back up.
Affected services
Updated
May 20, 2026 at 12:52am UTC
Our backup service is now online, though users may still experience slight performance degradation. Because the root cause depends entirely on an external vendor outage, we currently do not have an ETA for full restoration of our primary service. We appreciate your patience as we monitor the situation.
Affected services
Updated
May 20, 2026 at 12:35am UTC
We are working on restoring our backup service.
Affected services
Created
May 19, 2026 at 10:50pm UTC
A critical service disruption at an upstream external vendor has impacted our primary infrastructure; thus, all services are down. We are evaluating our options to restore service as quickly as possible.
Affected services