Requests timing out
Resolved
May 20, 2026 at 6:58pm UTC
Dashboard access has been resolved. Please clear your cache and cookies if you continue to experience issues.
Affected services
Updated
May 20, 2026 at 6:55pm UTC
The majority of dashboard issues have also been resolved. The only persistent issue is that hotel banners/logos may not show, and we are working on resolving this now.
Affected services
Updated
May 20, 2026 at 6:42pm UTC
Access to our iOS and Android applications, as well as API, have been fully restored. Dashboard access is still degraded.
Affected services
Updated
May 20, 2026 at 5:33pm UTC
We have identified the source of the error being a third-party vendor downtime. We are working with them to resolve the issue as soon as possible.
Affected services
Created
May 20, 2026 at 5:20pm UTC
Some users might experience requests timing out on client-side applications. We are currently investigating.
Affected services